Asgaros Forum < 1.15.15 - Admin+ SQL Injection via forum_id
Priority LOW 35CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The Asgaros Forum WordPress plugin before 1.15.15 does not validate or escape the forum_id parameter before using it in a SQL statement when editing a forum, leading to an SQL injection issue
Why it matters now
EPSS 0.01502 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Asgaros Forum (Unknown): 1.15.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Asgaros Forum | 1.15.15 to before 1.15.15 | 1.15.15 | Patch available | CNA |
- Asgaros Forum VendorUnknown Affected 1.15.15 to before 1.15.15 Fixed in 1.15.15 Patch available CNA
Remediation
- Fix · CNA Asgaros Forum (Unknown) Fixed in 1.15.15
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25045
- 2026-10-03 Alias added: GHSA-g4j5-9jfg-qj9h
References
More Asgaros Forum vulnerabilities
- TI-2023-05158 Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2021-07109 Asgaros Forum < 1.15.13 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-14871 WordPress Asgaros Forum Plugin <= 2.7.2 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2022-00336 Asgaros Forum < 2.0.0 - Subscriber+ Blind SQL Injection CVSS 3.1HIGH 8.8
- TI-2024-21335 WordPress Asgaros Forum plugin <= 2.8.0 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2022-20011 WordPress Asgaros Forum Plugin <= 2.2.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2021-25045 · CVE Program
- CVE-2021-25045 · NVD
- FIRST EPSS
- GHSA-g4j5-9jfg-qj9h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences