Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload
Priority HIGH 82CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-434.
Summary
The Asgaros Forum WordPress plugin before 2.7.1 allows forum administrators, who may not be WordPress (super-)administrators, to set insecure configuration that allows unauthenticated users to upload dangerous files (e.g. .php, .phtml), potentially leading to remote code execution.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01964 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Asgaros Forum (Unknown): 2.7.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Asgaros Forum | before 2.7.1 | 2.7.1 | Patch available | CNA |
- Asgaros Forum VendorUnknown Affected before 2.7.1 Fixed in 2.7.1 Patch available CNA
Remediation
- Fix · CNA Asgaros Forum (Unknown) Fixed in 2.7.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5604
- 2026-10-03 Alias added: GHSA-7862-qcxg-7h4c
References
More Asgaros Forum vulnerabilities
- TI-2021-07109 Asgaros Forum < 1.15.13 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-14871 WordPress Asgaros Forum Plugin <= 2.7.2 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2022-00336 Asgaros Forum < 2.0.0 - Subscriber+ Blind SQL Injection CVSS 3.1HIGH 8.8
- TI-2024-21335 WordPress Asgaros Forum plugin <= 2.8.0 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2022-20011 WordPress Asgaros Forum Plugin <= 2.2.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2021-07323 Asgaros Forum < 1.15.15 - Admin+ SQL Injection via forum_id CVSS 3.1HIGH 7.2
Sources
- CVE-2023-5604 · CVE Program
- CVE-2023-5604 · NVD
- FIRST EPSS
- GHSA-7862-qcxg-7h4c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences