Read the docs
TI-2022-00336 Aliases CVE-2022-0411GHSA-787f-w67j-6pv7

Asgaros Forum < 2.0.0 - Subscriber+ Blind SQL Injection

Priority MEDIUM 41CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The Asgaros Forum WordPress plugin before 2.0.0 does not sanitise and escape the post_id parameter before using it in a SQL statement via a REST route of the plugin (accessible to any authenticated user), leading to a SQL injection

Why it matters now

EPSS 0.01517 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Asgaros Forum (Unknown): 2.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAsgaros Forum2.0.0 to before 2.0.02.0.0Patch availableCNA
  • Asgaros Forum VendorUnknown Affected 2.0.0 to before 2.0.0 Fixed in 2.0.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:asgaros:asgaros_forum:*:*:*:*:*:wordpress:*:*before 2.0.0VulnerableAsgaros
  • cpe:2.3:a:asgaros:asgaros_forum:*:*:*:*:*:wordpress:*:* Versions before 2.0.0 Vulnerable ·Asgaros

Remediation

  • Fix · CNA Asgaros Forum (Unknown) Fixed in 2.0.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0411
  2. 2026-10-03 Alias added: GHSA-787f-w67j-6pv7

References

  • TI-2023-05158 Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
  • TI-2021-07109 Asgaros Forum < 1.15.13 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-14871 WordPress Asgaros Forum Plugin <= 2.7.2 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-21335 WordPress Asgaros Forum plugin <= 2.8.0 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
  • TI-2022-20011 WordPress Asgaros Forum Plugin <= 2.2.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2021-07323 Asgaros Forum < 1.15.15 - Admin+ SQL Injection via forum_id CVSS 3.1HIGH 7.2
See all 7 →

Sources