Improper Access Control in “Dolibarr”
Priority LOW 21CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
In “Dolibarr” application, 2.8.1 to 13.0.4 don’t restrict or incorrectly restricts access to a resource from an unauthorized actor. A low privileged attacker can modify the Private Note which only an administrator has rights to do, the affected field is at “/adherents/note.php?id=1” endpoint.
Why it matters now
EPSS 0.00702 53rd percentileScored 2026-11-07
Fix Fixed dolibarr/dolibarr (Packagist): 14.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dolibarr | dolibarr | 2.8.1 and later; up to 13.0.4 | — | No fix listed | CNA |
| — | dolibarr/dolibarr (Packagist) | 2.8.1 to before 14.0.0 | 14.0.0 | Patch available | GHSA-vxhc-c4qm-647p |
- dolibarr VendorDolibarr Affected 2.8.1 and later; up to 13.0.4 Fixed in — No fix listed CNA
- dolibarr/dolibarr (Packagist) Vendor— Affected 2.8.1 to before 14.0.0 Fixed in 14.0.0 Patch available GHSA-vxhc-c4qm-647p
Remediation
- Fix · GHSA-vxhc-c4qm-647p dolibarr/dolibarr (Packagist) Fixed in 14.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25954
- 2026-10-03 Alias added: GHSA-vxhc-c4qm-647p
References
More Dolibarr vulnerabilities
- TI-2018-07157 SQL injection vulnerability in Dolibarr before 7.0.2 allows remote attackers to execute… CVSS 3.0CRITICAL 9.8
- TI-2018-07158 Cross-site scripting (XSS) vulnerability in Dolibarr before 7.0.2 allows remote attackers… CVSS 3.0MEDIUM 6.1
- TI-2020-11130 Dolibarr before 11.0.5 allows low-privilege users to upload files of dangerous types… CVSS 3.1HIGH 8.8
- TI-2019-13844 Dolibarr ERP/CRM 3.0 through 10.0.3 allows XSS via the qty parameter to product/fournisseurs.php (product price screen). CVSS 3.1CRITICAL 9.8
- TI-2018-06539 SQL Injection vulnerability in Dolibarr before version 7.0.2 allows remote attackers to… CVSS 3.1CRITICAL 9.8
- TI-2018-12038 An issue was discovered in Dolibarr through 7.0.0. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2021-25954 · CVE Program
- CVE-2021-25954 · NVD
- FIRST EPSS
- GHSA-vxhc-c4qm-647p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences