[20210308] - Core - Path Traversal within joomla/archive zip class
Priority LOW 27CWE-22Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
An issue was discovered in Joomla! 3.0.0 through 3.9.24. Extracting an specifilcy crafted zip package could write files outside of the intended path.
Why it matters now
EPSS 0.01011 63rd percentileScored 2026-11-07
Fix Fixed joomla/archive (Packagist): 1.1.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Joomla! | Joomla! CMS | 3.0.0-3.9.24 | — | No fix listed | CNA |
| — | joomla/archive (Packagist) | before 1.1.10 | 1.1.10 | Patch available | GHSA-vgwr-773q-7j3c |
- Joomla! CMS VendorJoomla! Affected 3.0.0-3.9.24 Fixed in — No fix listed CNA
- joomla/archive (Packagist) Vendor— Affected before 1.1.10 Fixed in 1.1.10 Patch available GHSA-vgwr-773q-7j3c
Remediation
- Fix · GHSA-vgwr-773q-7j3c joomla/archive (Packagist) Fixed in 1.1.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-26028
- 2026-10-03 Alias added: GHSA-vgwr-773q-7j3c
References
Advisory 2
More Joomla! vulnerabilities
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-06410 SQL injection vulnerability in Joomla! 3.7.x before 3.7.1 allows attackers to execute… CVSS 3.0CRITICAL 9.8
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2016-07280 The register method in the UsersModelRegistration class in controllers/user.php in the… CVSS 3.0CRITICAL 9.8
- TI-2023-09555 [20230201] - Core - Improper access check in webservice endpoints KEVCVSS 3.1MEDIUM 5.3
- TI-2015-07045 Joomla! 1.5.x, 2.x, and 3.x before 3.4.6 allow remote attackers to conduct PHP object… CVSS 2.0HIGH 7.5
Sources
- CVE-2021-26028 · CVE Program
- CVE-2021-26028 · NVD
- FIRST EPSS
- GHSA-vgwr-773q-7j3c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences