Read the docs
TI-2021-08321 Aliases CVE-2021-26601GHSA-4q96-9f63-p7jj

ImpressCMS before 1.4.3 allows libraries/image-editor/image-edit.php image_temp Directory Traversal.

Priority MEDIUM 41CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

ImpressCMS before 1.4.3 allows libraries/image-editor/image-edit.php image_temp Directory Traversal.

Why it matters now

EPSS 0.03236 88th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed impresscms/impresscms (Packagist): 1.4.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—impresscms/impresscms (Packagist)before 1.4.31.4.3Patch availableGHSA-4q96-9f63-p7jj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • impresscms/impresscms (Packagist) Vendor— Affected before 1.4.3 Fixed in 1.4.3 Patch available GHSA-4q96-9f63-p7jj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:impresscms:impresscms:*:*:*:*:*:*:*:*before 1.4.3VulnerableImpressCMS
  • cpe:2.3:a:impresscms:impresscms:*:*:*:*:*:*:*:* Versions before 1.4.3 Vulnerable ·ImpressCMS

Remediation

  • Fix · GHSA-4q96-9f63-p7jj impresscms/impresscms (Packagist) Fixed in 1.4.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-26601
  2. 2026-10-03 Alias added: GHSA-4q96-9f63-p7jj

References

  • TI-2022-26365 ImpressCMS 1.4.4 - Unrestricted File Upload CVSS 4.0CRITICAL 9.3
  • TI-2019-15755 ImpressCMS 1.3.11 SQL Injection via bid Parameter CVSS 4.0HIGH 7.1
  • TI-2021-08319 ImpressCMS before 1.4.3 allows include/findusers.php groups SQL Injection. CVSS 3.1CRITICAL 9.8
  • TI-2023-19270 A cross-site scripting (XSS) vulnerability in ImpressCMS v1.4.5 and before allows… CVSS 3.1MEDIUM 4.8
  • TI-2022-08771 ImpressCMS before 1.4.2 allows unauthenticated remote code execution via .....///… CVSS 3.1CRITICAL 9.8
  • TI-2021-08320 ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant… CVSS 3.1CRITICAL 9.8
See all 20 →

Sources