CHECK-fail in `QuantizeAndDequantizeV4Grad`
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
TensorFlow is an end-to-end open source platform for machine learning. An attacker can trigger a denial of service via a `CHECK`-fail in `tf.raw_ops.QuantizeAndDequantizeV4Grad`. This is because the implementation does not validate the rank of the `input_*` tensors. In turn, this results in the tensors being passes as they are to `QuantizeAndDequantizePerChannelGradientImpl`. However, the `vec<T>` method, requires the rank to 1 and triggers a `CHECK` failure otherwise. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2 as this is the only other affected version.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-6g85-3hm8-83f9 |
| — | tensorflow-cpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-6g85-3hm8-83f9 |
| — | tensorflow-gpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-6g85-3hm8-83f9 |
- tensorflow VendorGoogle Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-6g85-3hm8-83f9
- tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-6g85-3hm8-83f9
- tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-6g85-3hm8-83f9
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.4.2
- Fix · GHSA-6g85-3hm8-83f9 tensorflow (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-6g85-3hm8-83f9 tensorflow-cpu (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-6g85-3hm8-83f9 tensorflow-gpu (PyPI) Fixed in 2.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29544
- 2026-10-03 Alias added: GHSA-6g85-3hm8-83f9
References
Other 6
- https://github.com/tensorflow/tensorflow/blob/95078c145b5a7a43ee046144005f733092756ab5/tensorflow/core/kernels/quantize_and_dequantize_op.cc#L162-L163
- https://github.com/tensorflow/tensorflow/blob/95078c145b5a7a43ee046144005f733092756ab5/tensorflow/core/kernels/quantize_and_dequantize_op.h#L295-L306
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-472.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-670.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-181.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-29544 · CVE Program
- CVE-2021-29544 · NVD
- FIRST EPSS
- GHSA-6g85-3hm8-83f9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences