Heap buffer overflow in `MaxPool3DGradGrad`
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-119 and the CVSS impact.
Summary
TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.MaxPool3DGradGrad` is vulnerable to a heap buffer overflow. The implementation(https://github.com/tensorflow/tensorflow/blob/596c05a159b6fbb9e39ca10b3f7753b7244fa1e9/tensorflow/core/kernels/pooling_ops_3d.cc#L694-L696) does not check that the initialization of `Pool3dParameters` completes successfully. Since the constructor(https://github.com/tensorflow/tensorflow/blob/596c05a159b6fbb9e39ca10b3f7753b7244fa1e9/tensorflow/core/kernels/pooling_ops_3d.cc#L48-L88) uses `OP_REQUIRES` to validate conditions, the first assertion that fails interrupts the initialization of `params`, making it contain invalid data. In turn, this might cause a heap buffer overflow, depending on default initialized values. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | 2.1.4, 2.2.3, 2.3.3, 2.4.2 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-cpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-cpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-cpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-cpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-gpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-gpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-gpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-7cqx-92hp-x6wh |
| — | tensorflow-gpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-7cqx-92hp-x6wh |
- tensorflow VendorGoogle Affected before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-cpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-gpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-7cqx-92hp-x6wh
- tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-7cqx-92hp-x6wh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2
- Fix · GHSA-7cqx-92hp-x6wh tensorflow (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-cpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-cpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-cpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-cpu (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-gpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-gpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-gpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-7cqx-92hp-x6wh tensorflow-gpu (PyPI) Fixed in 2.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29576
- 2026-10-03 Alias added: GHSA-7cqx-92hp-x6wh
References
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-504.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-702.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-213.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-29576 · CVE Program
- CVE-2021-29576 · NVD
- FIRST EPSS
- GHSA-7cqx-92hp-x6wh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences