Heap buffer overflow and undefined behavior in `FusedBatchNorm`
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-476, CWE-787 and the CVSS impact.
Summary
TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.FusedBatchNorm` is vulnerable to a heap buffer overflow. If the tensors are empty, the same implementation can trigger undefined behavior by dereferencing null pointers. The implementation(https://github.com/tensorflow/tensorflow/blob/57d86e0db5d1365f19adcce848dfc1bf89fdd4c7/tensorflow/core/kernels/fused_batch_norm_op.cc) fails to validate that `scale`, `offset`, `mean` and `variance` (the last two only when required) all have the same number of elements as the number of channels of `x`. This results in heap out of bounds reads when the buffers backing these tensors are indexed past their boundary. If the tensors are empty, the validation mentioned in the above paragraph would also trigger and prevent the undefined behavior. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | 2.1.4, 2.2.3, 2.3.3, 2.4.2 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-cpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-cpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-cpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-cpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-gpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-gpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-gpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-9xh4-23q4-v6wr |
| — | tensorflow-gpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-9xh4-23q4-v6wr |
- tensorflow VendorGoogle Affected before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-cpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-gpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-9xh4-23q4-v6wr
- tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-9xh4-23q4-v6wr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2
- Fix · GHSA-9xh4-23q4-v6wr tensorflow (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-cpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-cpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-cpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-cpu (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-gpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-gpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-gpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-9xh4-23q4-v6wr tensorflow-gpu (PyPI) Fixed in 2.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29583
- 2026-10-03 Alias added: GHSA-9xh4-23q4-v6wr
References
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-511.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-709.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-220.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-29583 · CVE Program
- CVE-2021-29583 · NVD
- FIRST EPSS
- GHSA-9xh4-23q4-v6wr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences