Stack overflow due to looping TFLite subgraph
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-835.
Summary
TensorFlow is an end-to-end open source platform for machine learning. TFlite graphs must not have loops between nodes. However, this condition was not checked and an attacker could craft models that would result in infinite loop during evaluation. In certain cases, the infinite loop would be replaced by stack overflow due to too many recursive calls. For example, the `While` implementation(https://github.com/tensorflow/tensorflow/blob/106d8f4fb89335a2c52d7c895b7a7485465ca8d9/tensorflow/lite/kernels/while.cc) could be tricked into a scneario where both the body and the loop subgraphs are the same. Evaluating one of the subgraphs means calling the `Eval` function for the other and this quickly exhaust all stack space. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range. Please consult our security guide(https://github.com/tensorflow/tensorflow/blob/master/SECURITY.md) for more information regarding the security model and how to contact us with issues and questions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | 2.1.4, 2.2.3, 2.3.3, 2.4.2 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-cpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-cpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-cpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-cpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-gpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-gpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-gpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-cwv3-863g-39vx |
| — | tensorflow-gpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-cwv3-863g-39vx |
- tensorflow VendorGoogle Affected before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-cwv3-863g-39vx
- tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-cwv3-863g-39vx
- tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-cwv3-863g-39vx
- tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-cwv3-863g-39vx
- tensorflow-cpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-cwv3-863g-39vx
- tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-cwv3-863g-39vx
- tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-cwv3-863g-39vx
- tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-cwv3-863g-39vx
- tensorflow-gpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-cwv3-863g-39vx
- tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-cwv3-863g-39vx
- tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-cwv3-863g-39vx
- tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-cwv3-863g-39vx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2
- Fix · GHSA-cwv3-863g-39vx tensorflow (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-cpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-cpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-cpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-cpu (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-gpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-gpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-gpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-cwv3-863g-39vx tensorflow-gpu (PyPI) Fixed in 2.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29591
- 2026-10-03 Alias added: GHSA-cwv3-863g-39vx
References
Patch 2
Other 5
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-519.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-717.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-228.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/106d8f4fb89335a2c52d7c895b7a7485465ca8d9/tensorflow/lite/kernels/while.cc
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-29591 · CVE Program
- CVE-2021-29591 · NVD
- FIRST EPSS
- GHSA-cwv3-863g-39vx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences