Crash in `tf.strings.substr` due to `CHECK`-fail
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a denial of service via `CHECK`-fail in `tf.strings.substr` with invalid arguments. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | 2.1.4, 2.2.3, 2.3.3, 2.4.2 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-cpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-cpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-cpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-cpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-gpu (PyPI) | before 2.1.4 | 2.1.4 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-gpu (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-gpu (PyPI) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-mmq6-q8r3-48fm |
| — | tensorflow-gpu (PyPI) | 2.4.0 to before 2.4.2 | 2.4.2 | Patch available | GHSA-mmq6-q8r3-48fm |
- tensorflow VendorGoogle Affected before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-cpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-gpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-mmq6-q8r3-48fm
- tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-mmq6-q8r3-48fm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2
- Fix · GHSA-mmq6-q8r3-48fm tensorflow (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-cpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-cpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-cpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-cpu (PyPI) Fixed in 2.4.2 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-gpu (PyPI) Fixed in 2.1.4 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-gpu (PyPI) Fixed in 2.2.3 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-gpu (PyPI) Fixed in 2.3.3 Advisory →
- Fix · GHSA-mmq6-q8r3-48fm tensorflow-gpu (PyPI) Fixed in 2.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29617
- 2026-10-03 Alias added: GHSA-mmq6-q8r3-48fm
References
Other 6
- https://github.com/tensorflow/issues/46900
- https://github.com/tensorflow/issues/46974
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-545.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-743.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-254.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-29617 · CVE Program
- CVE-2021-29617 · NVD
- FIRST EPSS
- GHSA-mmq6-q8r3-48fm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences