Read the docs
TI-2021-10326 Aliases CVE-2021-29618GHSA-xqfj-cr6q-pc8w

Crash in `tf.transpose` with complex inputs

Priority LOW 24CWE-755Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

TensorFlow is an end-to-end open source platform for machine learning. Passing a complex argument to `tf.transpose` at the same time as passing `conjugate=True` argument results in a crash. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.

Why it matters now

EPSS 0.0023 13th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.1.4, 2.2.3, 2.3.3 +1tensorflow (PyPI): 2.1.4, 2.2.3, 2.3.3 +1+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflowbefore 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.22.1.4, 2.2.3, 2.3.3, 2.4.2Patch availableCNA
—tensorflow (PyPI)before 2.1.42.1.4Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow (PyPI)2.2.0 to before 2.2.32.2.3Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow (PyPI)2.3.0 to before 2.3.32.3.3Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow (PyPI)2.4.0 to before 2.4.22.4.2Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-cpu (PyPI)before 2.1.42.1.4Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-cpu (PyPI)2.2.0 to before 2.2.32.2.3Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-cpu (PyPI)2.3.0 to before 2.3.32.3.3Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-cpu (PyPI)2.4.0 to before 2.4.22.4.2Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-gpu (PyPI)before 2.1.42.1.4Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-gpu (PyPI)2.2.0 to before 2.2.32.2.3Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-gpu (PyPI)2.3.0 to before 2.3.32.3.3Patch availableGHSA-xqfj-cr6q-pc8w
—tensorflow-gpu (PyPI)2.4.0 to before 2.4.22.4.2Patch availableGHSA-xqfj-cr6q-pc8w
  • tensorflow VendorGoogle Affected before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-xqfj-cr6q-pc8w
  • tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.2 Fixed in 2.4.2 Patch available GHSA-xqfj-cr6q-pc8w

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.1.4; 2.2.0 to before 2.2.3; 2.3.0 to before 2.3.3; 2.4.0 to before 2.4.2 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow (PyPI) Fixed in 2.1.4 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow (PyPI) Fixed in 2.2.3 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow (PyPI) Fixed in 2.3.3 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow (PyPI) Fixed in 2.4.2 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-cpu (PyPI) Fixed in 2.1.4 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-cpu (PyPI) Fixed in 2.2.3 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-cpu (PyPI) Fixed in 2.3.3 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-cpu (PyPI) Fixed in 2.4.2 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-gpu (PyPI) Fixed in 2.1.4 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-gpu (PyPI) Fixed in 2.2.3 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-gpu (PyPI) Fixed in 2.3.3 Advisory →
  • Fix · GHSA-xqfj-cr6q-pc8w tensorflow-gpu (PyPI) Fixed in 2.4.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-29618
  2. 2026-10-03 Alias added: GHSA-xqfj-cr6q-pc8w

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources