Information disclosure in moodle
Priority LOW 26CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
It was possible for a student to view their quiz grade before it had been released, using a quiz web service. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected
Why it matters now
EPSS 0.01033 63rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.5.18, 3.8.9, 3.9.7 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.18 | 3.5.18 | Patch available | GHSA-wx87-h539-4775 |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.9 | 3.8.9 | Patch available | GHSA-wx87-h539-4775 |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.7 | 3.9.7 | Patch available | GHSA-wx87-h539-4775 |
| — | moodle/moodle (Packagist) | 3.10 to before 3.10.4 | 3.10.4 | Patch available | GHSA-wx87-h539-4775 |
- moodle Vendor— Affected 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.18 Fixed in 3.5.18 Patch available GHSA-wx87-h539-4775
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.9 Fixed in 3.8.9 Patch available GHSA-wx87-h539-4775
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.7 Fixed in 3.9.7 Patch available GHSA-wx87-h539-4775
- moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.4 Fixed in 3.10.4 Patch available GHSA-wx87-h539-4775
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 3.5.18; 3.8.0 to before 3.8.9; 3.9.0 to before 3.9.7; 3.10.0 to before 3.10.4 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.5.18; 3.8.0 to before 3.8.9; 3.9.0 to before 3.9.7; 3.10.0 to before 3.10.4 Vulnerable ·Moodle
Remediation
- Fix · GHSA-wx87-h539-4775 moodle/moodle (Packagist) Fixed in 3.5.18 Advisory →
- Fix · GHSA-wx87-h539-4775 moodle/moodle (Packagist) Fixed in 3.8.9 Advisory →
- Fix · GHSA-wx87-h539-4775 moodle/moodle (Packagist) Fixed in 3.9.7 Advisory →
- Fix · GHSA-wx87-h539-4775 moodle/moodle (Packagist) Fixed in 3.10.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32473
- 2026-10-03 Alias added: GHSA-wx87-h539-4775
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2021-32473 · CVE Program
- CVE-2021-32473 · NVD
- FIRST EPSS
- GHSA-wx87-h539-4775 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences