SQL injection in moodle
Priority LOW 33CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Why it matters now
EPSS 0.00926 60th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.10.4, 3.9.7, 3.8.9 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.10 to before 3.10.4 | 3.10.4 | Patch available | GHSA-rvmc-8gmg-ggqr |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.7 | 3.9.7 | Patch available | GHSA-rvmc-8gmg-ggqr |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.9 | 3.8.9 | Patch available | GHSA-rvmc-8gmg-ggqr |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.18 | 3.5.18 | Patch available | GHSA-rvmc-8gmg-ggqr |
- moodle Vendor— Affected 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.4 Fixed in 3.10.4 Patch available GHSA-rvmc-8gmg-ggqr
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.7 Fixed in 3.9.7 Patch available GHSA-rvmc-8gmg-ggqr
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.9 Fixed in 3.8.9 Patch available GHSA-rvmc-8gmg-ggqr
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.18 Fixed in 3.5.18 Patch available GHSA-rvmc-8gmg-ggqr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 3.5.18; 3.8.0 to before 3.8.9; 3.9.0 to before 3.9.7; 3.10.0 to before 3.10.4 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.5.18; 3.8.0 to before 3.8.9; 3.9.0 to before 3.9.7; 3.10.0 to before 3.10.4 Vulnerable ·Moodle
Remediation
- Fix · GHSA-rvmc-8gmg-ggqr moodle/moodle (Packagist) Fixed in 3.10.4 Advisory →
- Fix · GHSA-rvmc-8gmg-ggqr moodle/moodle (Packagist) Fixed in 3.9.7 Advisory →
- Fix · GHSA-rvmc-8gmg-ggqr moodle/moodle (Packagist) Fixed in 3.8.9 Advisory →
- Fix · GHSA-rvmc-8gmg-ggqr moodle/moodle (Packagist) Fixed in 3.5.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32474
- 2026-10-03 Alias added: GHSA-rvmc-8gmg-ggqr
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2021-32474 · CVE Program
- CVE-2021-32474 · NVD
- FIRST EPSS
- GHSA-rvmc-8gmg-ggqr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences