Read the docs
TI-2021-12159 Aliases CVE-2021-32478GHSA-78fm-qhh8-8858

Cross-site scripting in moodle

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting, Spoofing
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-601.

Summary

The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.

Why it matters now

EPSS 0.01128 66th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.10.4, 3.9.7, 3.8.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8—No fix listedCNA
—moodle/moodle (Packagist)3.10 to before 3.10.43.10.4Patch availableGHSA-78fm-qhh8-8858
—moodle/moodle (Packagist)3.9 to before 3.9.73.9.7Patch availableGHSA-78fm-qhh8-8858
—moodle/moodle (Packagist)3.8 to before 3.8.93.8.9Patch availableGHSA-78fm-qhh8-8858
  • moodle Vendor— Affected 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.4 Fixed in 3.10.4 Patch available GHSA-78fm-qhh8-8858
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.7 Fixed in 3.9.7 Patch available GHSA-78fm-qhh8-8858
  • moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.9 Fixed in 3.8.9 Patch available GHSA-78fm-qhh8-8858

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.8.9; 3.9.0 to before 3.9.7; 3.10.0 to before 3.10.4VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.8.9; 3.9.0 to before 3.9.7; 3.10.0 to before 3.10.4 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-78fm-qhh8-8858 moodle/moodle (Packagist) Fixed in 3.10.4 Advisory →
  • Fix · GHSA-78fm-qhh8-8858 moodle/moodle (Packagist) Fixed in 3.9.7 Advisory →
  • Fix · GHSA-78fm-qhh8-8858 moodle/moodle (Packagist) Fixed in 3.8.9 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-32478
  2. 2026-10-03 Alias added: GHSA-78fm-qhh8-8858

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources