Creation of order credits was not validated by acl in admin orders
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-306.
Summary
Shopware is an open source eCommerce platform. Creation of order credits was not validated by ACL in admin orders. Users are recommend to update to the current version 6.4.1.1. You can get the update to 6.4.1.1 regularly via the Auto-Updater or directly via the download overview. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | platform | before 6.4.1.1 | 6.4.1.1 | Patch available | CNA |
| — | shopware/platform (Packagist) | before 6.4.1.1 | 6.4.1.1 | Patch available | GHSA-p696-gf58-9w97 |
- platform Vendorshopware Affected before 6.4.1.1 Fixed in 6.4.1.1 Patch available CNA
- shopware/platform (Packagist) Vendor— Affected before 6.4.1.1 Fixed in 6.4.1.1 Patch available GHSA-p696-gf58-9w97
Remediation
- Fix · CNA platform (shopware) Fixed in 6.4.1.1
- Fix · GHSA-p696-gf58-9w97 shopware/platform (Packagist) Fixed in 6.4.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32709
- 2026-10-03 Alias added: GHSA-p696-gf58-9w97
- 2026-10-31 EPSS moved to the 50th–90th percentile
References
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-32709 · CVE Program
- CVE-2021-32709 · NVD
- FIRST EPSS
- GHSA-p696-gf58-9w97 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences