Read the docs
TI-2021-12379 Aliases CVE-2021-32711GHSA-2p89-5f22-8qvf

Leak of information via Store-API

Priority MEDIUM 42CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021

Why it matters now

EPSS 0.01359 71st percentileScored 2026-11-07
Fix Fixed platform (shopware): 6.3.5.1shopware/platform (Packagist): 6.3.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformbefore 6.3.5.16.3.5.1Patch availableCNA
—shopware/platform (Packagist)before 6.3.5.16.3.5.1Patch availableGHSA-2p89-5f22-8qvf
  • platform Vendorshopware Affected before 6.3.5.1 Fixed in 6.3.5.1 Patch available CNA
  • shopware/platform (Packagist) Vendor— Affected before 6.3.5.1 Fixed in 6.3.5.1 Patch available GHSA-2p89-5f22-8qvf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.3.5.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.3.5.1 Vulnerable ·shopware

Remediation

  • Fix · CNA platform (shopware) Fixed in 6.3.5.1
  • Fix · GHSA-2p89-5f22-8qvf shopware/platform (Packagist) Fixed in 6.3.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-32711
  2. 2026-10-03 Alias added: GHSA-2p89-5f22-8qvf

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources