Information leakage in Error Handler
Priority LOW 26CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Shopware is an open source eCommerce platform. Versions prior to 5.6.10 are vulnerable to system information leakage in error handling. Users are recommend to update to version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview.
Why it matters now
EPSS 0.01135 66th percentileScored 2026-11-07
Fix Fixed shopware (shopware): 5.6.10shopware/shopware (Packagist): 5.6.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | shopware | before 5.6.10 | 5.6.10 | Patch available | CNA |
| — | shopware/shopware (Packagist) | before 5.6.10 | 5.6.10 | Patch available | GHSA-qwpp-fgrj-h78q |
- shopware Vendorshopware Affected before 5.6.10 Fixed in 5.6.10 Patch available CNA
- shopware/shopware (Packagist) Vendor— Affected before 5.6.10 Fixed in 5.6.10 Patch available GHSA-qwpp-fgrj-h78q
Remediation
- Fix · CNA shopware (shopware) Fixed in 5.6.10
- Fix · GHSA-qwpp-fgrj-h78q shopware/shopware (Packagist) Fixed in 5.6.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32712
- 2026-10-03 Alias added: GHSA-qwpp-fgrj-h78q
References
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-32712 · CVE Program
- CVE-2021-32712 · NVD
- FIRST EPSS
- GHSA-qwpp-fgrj-h78q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences