Apache Hadoop Privilege escalation vulnerability
Priority MEDIUM 45CWE-24Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264 and CWE-502.
Summary
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Why it matters now
EPSS 0.04033 90th percentileScored 2026-11-07
Fix Partial org.apache.hadoop:hadoop-yarn-server-common (Maven): 2.10.2, 3.2.3, 3.3.2Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Hadoop | 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1 | — | No fix listed | CNA |
| — | org.apache.hadoop:hadoop-yarn-server-common (Maven) | 2.2.0 to before 2.10.2 | 2.10.2 | Patch available | GHSA-58jx-f5rf-qgqf |
| — | org.apache.hadoop:hadoop-yarn-server-common (Maven) | 3.0.0 to before 3.2.3 | 3.2.3 | Patch available | GHSA-58jx-f5rf-qgqf |
| — | org.apache.hadoop:hadoop-yarn-server-common (Maven) | 3.3.0 to before 3.3.2 | 3.3.2 | Patch available | GHSA-58jx-f5rf-qgqf |
- Apache Hadoop VendorApache Affected 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1 Fixed in — No fix listed CNA
- org.apache.hadoop:hadoop-yarn-server-common (Maven) Vendor— Affected 2.2.0 to before 2.10.2 Fixed in 2.10.2 Patch available GHSA-58jx-f5rf-qgqf
- org.apache.hadoop:hadoop-yarn-server-common (Maven) Vendor— Affected 3.0.0 to before 3.2.3 Fixed in 3.2.3 Patch available GHSA-58jx-f5rf-qgqf
- org.apache.hadoop:hadoop-yarn-server-common (Maven) Vendor— Affected 3.3.0 to before 3.3.2 Fixed in 3.3.2 Patch available GHSA-58jx-f5rf-qgqf
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hadoop:*:*:*:*:*:*:*:* | 2.2.0 to before 2.10.2; 3.0.1 to before 3.2.3; 3.3.0 to before 3.3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha1:*:*:*:*:*:* | 3.0.0 alpha1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha2:*:*:*:*:*:* | 3.0.0 alpha2 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha3:*:*:*:*:*:* | 3.0.0 alpha3 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha4:*:*:*:*:*:* | 3.0.0 alpha4 | Vulnerable | Apache |
- cpe:2.3:a:apache:hadoop:*:*:*:*:*:*:*:* Versions 2.2.0 to before 2.10.2; 3.0.1 to before 3.2.3; 3.3.0 to before 3.3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha1:*:*:*:*:*:* Versions 3.0.0 alpha1 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha2:*:*:*:*:*:* Versions 3.0.0 alpha2 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha3:*:*:*:*:*:* Versions 3.0.0 alpha3 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha4:*:*:*:*:*:* Versions 3.0.0 alpha4 Vulnerable ·Apache
Remediation
- Fix · GHSA-58jx-f5rf-qgqf org.apache.hadoop:hadoop-yarn-server-common (Maven) Fixed in 2.10.2 Advisory →
- Fix · GHSA-58jx-f5rf-qgqf org.apache.hadoop:hadoop-yarn-server-common (Maven) Fixed in 3.2.3 Advisory →
- Fix · GHSA-58jx-f5rf-qgqf org.apache.hadoop:hadoop-yarn-server-common (Maven) Fixed in 3.3.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Integration Data Virtualisation Operator | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Data Grid 7 | Affected | No fix planned: Out of support scope |
Not affected: 4 products
- Logging Subsystem for Red Hat OpenShift
- Red Hat Fuse 7
- Red Hat Integration Camel K 1
- Red Hat Integration Camel Quarkus 1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33036
- 2026-10-03 Alias added: GHSA-58jx-f5rf-qgqf
- 2026-10-14 EPSS moved to the 90th–95th percentile
References
Advisory 4
Other 5
- https://github.com/apache/hadoop/commit/227d64ab59e8aa6477769b2542ad0cd7a6d855cb
- https://github.com/apache/hadoop/commit/45801fba8b00257ab32c02a7d1a05948ba687a49
- https://github.com/apache/hadoop/commit/ba041fe6d34215f075e0a7b2078d7273147e14b7
- https://github.com/apache/hadoop
- https://security.netapp.com/advisory/ntap-20220722-0003
More Apache Hadoop vulnerabilities
- TI-2019-12818 Connect2id Nimbus JOSE+JWT before v7.9 can throw various uncaught exceptions while… CVSS 3.1CRITICAL 9.8
- TI-2022-09898 Arbitrary file write in FileUtil#unpackEntries on Windows CVSS 3.1CRITICAL 9.8
- TI-2022-08881 Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar CVSS 3.1CRITICAL 9.8
- TI-2021-15353 Heap buffer overflow in libhdfs native library CVSS 3.1CRITICAL 9.8
- TI-2018-05786 Path traversal in Apache Hadoop CVSS 3.0HIGH 8.8
- TI-2017-11489 Information disclosure in Apache Hadoop CVSS 3.0CRITICAL 9.8
Sources
- CVE-2021-33036 · CVE Program
- CVE-2021-33036 · NVD
- FIRST EPSS
- GHSA-58jx-f5rf-qgqf · GitHub Advisory Database · CC BY 4.0
- CVE-2021-33036 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences