A reflected cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows…
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A reflected cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or HTML via the ref parameter to a page about an arbitrary product, e.g., a product/insert-product-name-here.html/ref= URL.
Why it matters now
EPSS 0.02916 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed com.shopizer:shopizer (Maven): 2.17.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | com.shopizer:shopizer (Maven) | before 2.17.0 | 2.17.0 | Patch available | GHSA-378p-hrq3-x4p3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- com.shopizer:shopizer (Maven) Vendor— Affected before 2.17.0 Fixed in 2.17.0 Patch available GHSA-378p-hrq3-x4p3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:shopizer:shopizer:*:*:*:*:*:*:*:* | before 2.17.0 | Vulnerable | shopizer-ecommerce |
- cpe:2.3:a:shopizer:shopizer:*:*:*:*:*:*:*:* Versions before 2.17.0 Vulnerable ·shopizer-ecommerce
Remediation
- Fix · GHSA-378p-hrq3-x4p3 com.shopizer:shopizer (Maven) Fixed in 2.17.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33562
- 2026-10-03 Alias added: GHSA-378p-hrq3-x4p3
References
More shopizer-ecommerce Shopizer vulnerabilities
- TI-2025-32372 An issue was discovered in Shopizer 3.2.7. CVSS 3.1HIGH 8.1
- TI-2022-07236 Shopizer - Insufficient Session Expiration CVSS 3.1HIGH 8.8
- TI-2020-08880 Potential remote code execution in Shopizer CVSS 3.1CRITICAL 9.1
- TI-2014-04073 Shopizer 1.1.5 and earlier allows remote attackers to modify the account settings of… CVSS 2.0MEDIUM 6.8
- TI-2014-04072 Shopizer 1.1.5 and earlier allows remote attackers to reduce the total cost of their… CVSS 2.0MEDIUM 6.4
- TI-2014-04074 Multiple cross-site request forgery (CSRF) vulnerabilities in Shopizer 1.1.5 and earlier… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2021-33562 · CVE Program
- CVE-2021-33562 · NVD
- FIRST EPSS
- GHSA-378p-hrq3-x4p3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences