Apache Geode project log file redaction of sensitive information vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-532.
Summary
Apache Geode versions up to 1.12.4 and 1.13.4 are vulnerable to a log file redaction of sensitive information flaw when using values that begin with characters other than letters or numbers for passwords and security properties with the prefix "sysprop-", "javax.net.ssl", or "security-". This issue is fixed by overhauling the log file redaction in Apache Geode versions 1.12.5, 1.13.5, and 1.14.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Geode | Apache Geode – 1.12.4 | — | No fix listed | CNA |
| — | org.apache.geode:geode-core (Maven) | before 1.12.5 | 1.12.5 | Patch available | GHSA-mw25-f5r2-hpc6 |
| — | org.apache.geode:geode-core (Maven) | 1.13.0 to before 1.13.5 | 1.13.5 | Patch available | GHSA-mw25-f5r2-hpc6 |
- Apache Geode VendorApache Affected Apache Geode – 1.12.4 Fixed in — No fix listed CNA
- org.apache.geode:geode-core (Maven) Vendor— Affected before 1.12.5 Fixed in 1.12.5 Patch available GHSA-mw25-f5r2-hpc6
- org.apache.geode:geode-core (Maven) Vendor— Affected 1.13.0 to before 1.13.5 Fixed in 1.13.5 Patch available GHSA-mw25-f5r2-hpc6
Remediation
- Fix · GHSA-mw25-f5r2-hpc6 org.apache.geode:geode-core (Maven) Fixed in 1.12.5 Advisory →
- Fix · GHSA-mw25-f5r2-hpc6 org.apache.geode:geode-core (Maven) Fixed in 1.13.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-34797
- 2026-10-03 Alias added: GHSA-mw25-f5r2-hpc6
References
More Apache Geode vulnerabilities
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2017-11466 Deserialization of untrusted data in Apache Geode CVSS 3.0CRITICAL 9.8
- TI-2022-17225 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-34797 · CVE Program
- CVE-2021-34797 · NVD
- FIRST EPSS
- GHSA-mw25-f5r2-hpc6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences