Read the docs
TI-2021-14743 Aliases CVE-2021-36395GHSA-273w-7fxj-pcp6

Uncontrolled resource consumption in Moodle

Priority LOW 34CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

In Moodle, the file repository's URL parsing required additional recursion handling to mitigate the risk of recursion denial of service.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00734 54th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.1, 3.10.5, 3.9.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Moodle3.11, 3.10 to 3.10.4, 3.9 to 3.9.7 and earlier unsupported versions—No fix listedCNA
—moodle/moodle (Packagist)3.11.0-beta to before 3.11.13.11.1Patch availableGHSA-273w-7fxj-pcp6
—moodle/moodle (Packagist)3.10.0-beta to before 3.10.53.10.5Patch availableGHSA-273w-7fxj-pcp6
—moodle/moodle (Packagist)before 3.9.83.9.8Patch availableGHSA-273w-7fxj-pcp6
  • Moodle Vendor— Affected 3.11, 3.10 to 3.10.4, 3.9 to 3.9.7 and earlier unsupported versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.11.0-beta to before 3.11.1 Fixed in 3.11.1 Patch available GHSA-273w-7fxj-pcp6
  • moodle/moodle (Packagist) Vendor— Affected 3.10.0-beta to before 3.10.5 Fixed in 3.10.5 Patch available GHSA-273w-7fxj-pcp6
  • moodle/moodle (Packagist) Vendor— Affected before 3.9.8 Fixed in 3.9.8 Patch available GHSA-273w-7fxj-pcp6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.9.8; 3.10.0 to before 3.10.5; 3.11.0 to before 3.11.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.9.8; 3.10.0 to before 3.10.5; 3.11.0 to before 3.11.1 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-273w-7fxj-pcp6 moodle/moodle (Packagist) Fixed in 3.11.1 Advisory →
  • Fix · GHSA-273w-7fxj-pcp6 moodle/moodle (Packagist) Fixed in 3.10.5 Advisory →
  • Fix · GHSA-273w-7fxj-pcp6 moodle/moodle (Packagist) Fixed in 3.9.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-36395
  2. 2026-10-03 Alias added: GHSA-273w-7fxj-pcp6

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources