In Moodle, ID numbers exported in HTML data formats required additional sanitizing to prevent a local stored XSS risk.
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Moodle, ID numbers exported in HTML data formats required additional sanitizing to prevent a local stored XSS risk.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0053 45th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.1, 3.10.5, 3.9.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | 3.11, 3.10 to 3.10.4, 3.9 to 3.9.7 and earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.11.0-beta to before 3.11.1 | 3.11.1 | Patch available | GHSA-g6h6-4fp6-w33w |
| — | moodle/moodle (Packagist) | 3.10.0-beta to before 3.10.5 | 3.10.5 | Patch available | GHSA-g6h6-4fp6-w33w |
| — | moodle/moodle (Packagist) | before 3.9.8 | 3.9.8 | Patch available | GHSA-g6h6-4fp6-w33w |
- Moodle Vendor— Affected 3.11, 3.10 to 3.10.4, 3.9 to 3.9.7 and earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.11.0-beta to before 3.11.1 Fixed in 3.11.1 Patch available GHSA-g6h6-4fp6-w33w
- moodle/moodle (Packagist) Vendor— Affected 3.10.0-beta to before 3.10.5 Fixed in 3.10.5 Patch available GHSA-g6h6-4fp6-w33w
- moodle/moodle (Packagist) Vendor— Affected before 3.9.8 Fixed in 3.9.8 Patch available GHSA-g6h6-4fp6-w33w
Remediation
- Fix · GHSA-g6h6-4fp6-w33w moodle/moodle (Packagist) Fixed in 3.11.1 Advisory →
- Fix · GHSA-g6h6-4fp6-w33w moodle/moodle (Packagist) Fixed in 3.10.5 Advisory →
- Fix · GHSA-g6h6-4fp6-w33w moodle/moodle (Packagist) Fixed in 3.9.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36401
- 2026-10-03 Alias added: GHSA-g6h6-4fp6-w33w
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2021-36401 · CVE Program
- CVE-2021-36401 · NVD
- FIRST EPSS
- GHSA-g6h6-4fp6-w33w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences