Read the docs
TI-2021-15520 Aliases CVE-2021-37645GHSA-9w2p-5mgw-p94c

Integer overflow due to conversion to unsigned in TensorFlow

Priority LOW 24CWE-681Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

TensorFlow is an end-to-end open source platform for machine learning. In affected versions the implementation of `tf.raw_ops.QuantizeAndDequantizeV4Grad` is vulnerable to an integer overflow issue caused by converting a signed integer value to an unsigned one and then allocating memory based on this value. The [implementation](https://github.com/tensorflow/tensorflow/blob/8d72537c6abf5a44103b57b9c2e22c14f5f49698/tensorflow/core/kernels/quantize_and_dequantize_op.cc#L126) uses the `axis` value as the size argument to `absl::InlinedVector` constructor. But, the constructor uses an unsigned type for the argument, so the implicit conversion transforms the negative value to a large integer. We have patched the issue in GitHub commit 96f364a1ca3009f98980021c4b32be5fdcca33a1. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, and TensorFlow 2.4.3, as these are also affected and still in supported range.

Why it matters now

EPSS 0.00152 4th percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.5.1, 2.4.3tensorflow (PyPI): 2.4.3, 2.5.1+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.5.0 to before 2.5.1; before 2.4.32.5.1, 2.4.3Patch availableCNA
—tensorflow (PyPI)before 2.4.32.4.3Patch availableGHSA-9w2p-5mgw-p94c
—tensorflow (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-9w2p-5mgw-p94c
—tensorflow-cpu (PyPI)before 2.4.32.4.3Patch availableGHSA-9w2p-5mgw-p94c
—tensorflow-cpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-9w2p-5mgw-p94c
—tensorflow-gpu (PyPI)before 2.4.32.4.3Patch availableGHSA-9w2p-5mgw-p94c
—tensorflow-gpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-9w2p-5mgw-p94c
  • tensorflow VendorGoogle Affected 2.5.0 to before 2.5.1; before 2.4.3 Fixed in 2.5.1, 2.4.3 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.4.3 Fixed in 2.4.3 Patch available GHSA-9w2p-5mgw-p94c
  • tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-9w2p-5mgw-p94c
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.4.3 Fixed in 2.4.3 Patch available GHSA-9w2p-5mgw-p94c
  • tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-9w2p-5mgw-p94c
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.4.3 Fixed in 2.4.3 Patch available GHSA-9w2p-5mgw-p94c
  • tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-9w2p-5mgw-p94c

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:*2.6.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:*2.6.0 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:*2.6.0 rc2VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* Versions 2.6.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* Versions 2.6.0 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* Versions 2.6.0 rc2 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.5.1, 2.4.3
  • Fix · GHSA-9w2p-5mgw-p94c tensorflow (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-9w2p-5mgw-p94c tensorflow (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-9w2p-5mgw-p94c tensorflow-cpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-9w2p-5mgw-p94c tensorflow-cpu (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-9w2p-5mgw-p94c tensorflow-gpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-9w2p-5mgw-p94c tensorflow-gpu (PyPI) Fixed in 2.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37645
  2. 2026-10-03 Alias added: GHSA-9w2p-5mgw-p94c

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources