Read the docs
TI-2021-15524 Aliases CVE-2021-37649GHSA-6gv8-p3vj-pxvr

Null pointer dereference in `UncompressElement` in TensorFlow

Priority LOW 33CWE-476Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-476.

Summary

TensorFlow is an end-to-end open source platform for machine learning. The code for `tf.raw_ops.UncompressElement` can be made to trigger a null pointer dereference. The [implementation](https://github.com/tensorflow/tensorflow/blob/f24faa153ad31a4b51578f8181d3aaab77a1ddeb/tensorflow/core/kernels/data/experimental/compression_ops.cc#L50-L53) obtains a pointer to a `CompressedElement` from a `Variant` tensor and then proceeds to dereference it for decompressing. There is no check that the `Variant` tensor contained a `CompressedElement`, so the pointer is actually `nullptr`. We have patched the issue in GitHub commit 7bdf50bb4f5c54a4997c379092888546c97c3ebd. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Why it matters now

EPSS 0.0016 5th percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.5.1, 2.4.3, 2.3.4tensorflow (PyPI): 2.3.4, 2.4.3, 2.5.1+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.42.5.1, 2.4.3, 2.3.4Patch availableCNA
—tensorflow (PyPI)before 2.3.42.3.4Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow-cpu (PyPI)before 2.3.42.3.4Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow-cpu (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow-cpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow-gpu (PyPI)before 2.3.42.3.4Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow-gpu (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-6gv8-p3vj-pxvr
—tensorflow-gpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-6gv8-p3vj-pxvr
  • tensorflow VendorGoogle Affected 2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.4 Fixed in 2.5.1, 2.4.3, 2.3.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-6gv8-p3vj-pxvr
  • tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-6gv8-p3vj-pxvr

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:*2.6.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:*2.6.0 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:*2.6.0 rc2VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* Versions 2.6.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* Versions 2.6.0 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* Versions 2.6.0 rc2 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.5.1, 2.4.3, 2.3.4
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow-cpu (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow-cpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow-cpu (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow-gpu (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow-gpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-6gv8-p3vj-pxvr tensorflow-gpu (PyPI) Fixed in 2.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37649
  2. 2026-10-03 Alias added: GHSA-6gv8-p3vj-pxvr

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources