Read the docs
TI-2021-15552 Aliases CVE-2021-37677GHSA-qfpc-5pjr-mh26

Missing validation in shape inference for `Dequantize` in TensorFlow

Priority LOW 24CWE-20Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

TensorFlow is an end-to-end open source platform for machine learning. In affected versions the shape inference code for `tf.raw_ops.Dequantize` has a vulnerability that could trigger a denial of service via a segfault if an attacker provides invalid arguments. The shape inference [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/ops/array_ops.cc#L2999-L3014) uses `axis` to select between two different values for `minmax_rank` which is then used to retrieve tensor dimensions. However, code assumes that `axis` can be either `-1` or a value greater than `-1`, with no validation for the other values. We have patched the issue in GitHub commit da857cfa0fde8f79ad0afdbc94e88b5d4bbec764. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Why it matters now

EPSS 0.00148 3rd percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.5.1, 2.4.3, 2.3.4tensorflow (PyPI): 2.3.4, 2.4.3, 2.5.1+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.42.5.1, 2.4.3, 2.3.4Patch availableCNA
—tensorflow (PyPI)before 2.3.42.3.4Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow-cpu (PyPI)before 2.3.42.3.4Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow-cpu (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow-cpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow-gpu (PyPI)before 2.3.42.3.4Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow-gpu (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-qfpc-5pjr-mh26
—tensorflow-gpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-qfpc-5pjr-mh26
  • tensorflow VendorGoogle Affected 2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.4 Fixed in 2.5.1, 2.4.3, 2.3.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-qfpc-5pjr-mh26
  • tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-qfpc-5pjr-mh26

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:*2.6.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:*2.6.0 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:*2.6.0 rc2VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* Versions 2.6.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* Versions 2.6.0 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* Versions 2.6.0 rc2 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.5.1, 2.4.3, 2.3.4
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow-cpu (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow-cpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow-cpu (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow-gpu (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow-gpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-qfpc-5pjr-mh26 tensorflow-gpu (PyPI) Fixed in 2.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37677
  2. 2026-10-03 Alias added: GHSA-qfpc-5pjr-mh26

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources