Division by zero in TensorFlow Lite division operations
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-369.
Summary
TensorFlow is an end-to-end open source platform for machine learning. In affected versions the implementation of division in TFLite is [vulnerable to a division by 0 error](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/lite/kernels/div.cc). There is no check that the divisor tensor does not contain zero elements. We have patched the issue in GitHub commit 1e206baedf8bef0334cca3eb92bab134ef525a28. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.4 | 2.5.1, 2.4.3, 2.3.4 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.3.4 | 2.3.4 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow (PyPI) | 2.4.0 to before 2.4.3 | 2.4.3 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow (PyPI) | 2.5.0 to before 2.5.1 | 2.5.1 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow-cpu (PyPI) | before 2.3.4 | 2.3.4 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow-cpu (PyPI) | 2.4.0 to before 2.4.3 | 2.4.3 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow-cpu (PyPI) | 2.5.0 to before 2.5.1 | 2.5.1 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow-gpu (PyPI) | before 2.3.4 | 2.3.4 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow-gpu (PyPI) | 2.4.0 to before 2.4.3 | 2.4.3 | Patch available | GHSA-rhrq-64mq-hf9h |
| — | tensorflow-gpu (PyPI) | 2.5.0 to before 2.5.1 | 2.5.1 | Patch available | GHSA-rhrq-64mq-hf9h |
- tensorflow VendorGoogle Affected 2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.4 Fixed in 2.5.1, 2.4.3, 2.3.4 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow-cpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow-gpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-rhrq-64mq-hf9h
- tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-rhrq-64mq-hf9h
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* | 2.6.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* | 2.6.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* | 2.6.0 rc2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* Versions 2.6.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* Versions 2.6.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* Versions 2.6.0 rc2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.5.1, 2.4.3, 2.3.4
- Fix · GHSA-rhrq-64mq-hf9h tensorflow (PyPI) Fixed in 2.3.4 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow (PyPI) Fixed in 2.4.3 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow (PyPI) Fixed in 2.5.1 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow-cpu (PyPI) Fixed in 2.3.4 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow-cpu (PyPI) Fixed in 2.4.3 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow-cpu (PyPI) Fixed in 2.5.1 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow-gpu (PyPI) Fixed in 2.3.4 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow-gpu (PyPI) Fixed in 2.4.3 Advisory →
- Fix · GHSA-rhrq-64mq-hf9h tensorflow-gpu (PyPI) Fixed in 2.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-37683
- 2026-10-03 Alias added: GHSA-rhrq-64mq-hf9h
References
Advisory 2
Other 5
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-596.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-794.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-305.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/lite/kernels/div.cc
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-37683 · CVE Program
- CVE-2021-37683 · NVD
- FIRST EPSS
- GHSA-rhrq-64mq-hf9h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences