Infinite loop in TensorFlow Lite
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-835.
Summary
TensorFlow is an end-to-end open source platform for machine learning. In affected versions the strided slice implementation in TFLite has a logic bug which can allow an attacker to trigger an infinite loop. This arises from newly introduced support for [ellipsis in axis definition](https://github.com/tensorflow/tensorflow/blob/149562d49faa709ea80df1d99fc41d005b81082a/tensorflow/lite/kernels/strided_slice.cc#L103-L122). An attacker can craft a model such that `ellipsis_end_idx` is smaller than `i` (e.g., always negative). In this case, the inner loop does not increase `i` and the `continue` statement causes execution to skip over the preincrement at the end of the outer loop. We have patched the issue in GitHub commit dfa22b348b70bb89d6d6ec0ff53973bacb4f4695. TensorFlow 2.6.0 is the only affected version.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.6.0rc0 to before 2.6.0rc2 | 2.6.0rc2 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.6.0rc0 to before 2.6.0rc2 | 2.6.0rc2 | Patch available | GHSA-mhhc-q96p-mfm9 |
| — | tensorflow-cpu (PyPI) | 2.6.0rc0 to before 2.6.0rc2 | 2.6.0rc2 | Patch available | GHSA-mhhc-q96p-mfm9 |
| — | tensorflow-gpu (PyPI) | 2.6.0rc0 to before 2.6.0rc2 | 2.6.0rc2 | Patch available | GHSA-mhhc-q96p-mfm9 |
- tensorflow VendorGoogle Affected 2.6.0rc0 to before 2.6.0rc2 Fixed in 2.6.0rc2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.6.0rc0 to before 2.6.0rc2 Fixed in 2.6.0rc2 Patch available GHSA-mhhc-q96p-mfm9
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0rc0 to before 2.6.0rc2 Fixed in 2.6.0rc2 Patch available GHSA-mhhc-q96p-mfm9
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0rc0 to before 2.6.0rc2 Fixed in 2.6.0rc2 Patch available GHSA-mhhc-q96p-mfm9
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* | 2.6.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* | 2.6.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* | 2.6.0 rc2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* Versions 2.6.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* Versions 2.6.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* Versions 2.6.0 rc2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.0rc2
- Fix · GHSA-mhhc-q96p-mfm9 tensorflow (PyPI) Fixed in 2.6.0rc2 Advisory →
- Fix · GHSA-mhhc-q96p-mfm9 tensorflow-cpu (PyPI) Fixed in 2.6.0rc2 Advisory →
- Fix · GHSA-mhhc-q96p-mfm9 tensorflow-gpu (PyPI) Fixed in 2.6.0rc2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-37686
- 2026-10-03 Alias added: GHSA-mhhc-q96p-mfm9
References
Advisory 2
Other 8
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-599.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-797.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-308.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.4
- https://github.com/tensorflow/tensorflow/releases/tag/v2.4.3
- https://github.com/tensorflow/tensorflow/releases/tag/v2.5.1
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.0
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-37686 · CVE Program
- CVE-2021-37686 · NVD
- FIRST EPSS
- GHSA-mhhc-q96p-mfm9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences