Read the docs
TI-2021-15564 Aliases CVE-2021-37689GHSA-wf5p-c75w-w3wh

Null pointer dereference in TensorFlow Lite MLIR optimizations

Priority LOW 33CWE-476Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-476.

Summary

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can craft a TFLite model that would trigger a null pointer dereference, which would result in a crash and denial of service. This is caused by the MLIR optimization of `L2NormalizeReduceAxis` operator. The [implementation](https://github.com/tensorflow/tensorflow/blob/149562d49faa709ea80df1d99fc41d005b81082a/tensorflow/compiler/mlir/lite/transforms/optimize.cc#L67-L70) unconditionally dereferences a pointer to an iterator to a vector without checking that the vector has elements. We have patched the issue in GitHub commit d6b57f461b39fd1aa8c1b870f1b974aac3554955. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Why it matters now

EPSS 0.00165 5th percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.5.1, 2.4.3, 2.3.4tensorflow (PyPI): 2.3.4, 2.4.3, 2.5.1+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.42.5.1, 2.4.3, 2.3.4Patch availableCNA
—tensorflow (PyPI)before 2.3.42.3.4Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow-cpu (PyPI)before 2.3.42.3.4Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow-cpu (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow-cpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow-gpu (PyPI)before 2.3.42.3.4Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow-gpu (PyPI)2.4.0 to before 2.4.32.4.3Patch availableGHSA-wf5p-c75w-w3wh
—tensorflow-gpu (PyPI)2.5.0 to before 2.5.12.5.1Patch availableGHSA-wf5p-c75w-w3wh
  • tensorflow VendorGoogle Affected 2.5.0 to before 2.5.1; 2.4.0 to before 2.4.3; before 2.3.4 Fixed in 2.5.1, 2.4.3, 2.3.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow-cpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow-gpu (PyPI) Vendor— Affected 2.4.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-wf5p-c75w-w3wh
  • tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-wf5p-c75w-w3wh

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:*2.5.0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:*2.6.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:*2.6.0 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:*2.6.0 rc2VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.3.0 to before 2.3.4; 2.4.0 to before 2.4.3 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc0:*:*:*:*:*:* Versions 2.6.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc1:*:*:*:*:*:* Versions 2.6.0 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.6.0:rc2:*:*:*:*:*:* Versions 2.6.0 rc2 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.5.1, 2.4.3, 2.3.4
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow-cpu (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow-cpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow-cpu (PyPI) Fixed in 2.5.1 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow-gpu (PyPI) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow-gpu (PyPI) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-wf5p-c75w-w3wh tensorflow-gpu (PyPI) Fixed in 2.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37689
  2. 2026-10-03 Alias added: GHSA-wf5p-c75w-w3wh

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources