Insecure direct object reference of log files of the Import/Export feature
Priority LOW 30CWE-532Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-532 and CWE-639.
Summary
Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a vulnerability involving an insecure direct object reference of log files of the Import/Export feature. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.
Why it matters now
EPSS 0.00774 55th percentileScored 2026-11-07
Fix Fixed shopware/platform (Packagist): 6.4.3.1shopware/core (Packagist): 6.4.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | platform | up to 6.4.3.0 | — | No fix listed | CNA |
| — | shopware/platform (Packagist) | before 6.4.3.1 | 6.4.3.1 | Patch available | GHSA-54gp-qff8-946c |
| — | shopware/core (Packagist) | before 6.4.3.1 | 6.4.3.1 | Patch available | GHSA-54gp-qff8-946c |
- platform Vendorshopware Affected up to 6.4.3.0 Fixed in — No fix listed CNA
- shopware/platform (Packagist) Vendor— Affected before 6.4.3.1 Fixed in 6.4.3.1 Patch available GHSA-54gp-qff8-946c
- shopware/core (Packagist) Vendor— Affected before 6.4.3.1 Fixed in 6.4.3.1 Patch available GHSA-54gp-qff8-946c
Remediation
- Fix · GHSA-54gp-qff8-946c shopware/platform (Packagist) Fixed in 6.4.3.1 Advisory →
- Fix · GHSA-54gp-qff8-946c shopware/core (Packagist) Fixed in 6.4.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-37709
- 2026-10-03 Alias added: GHSA-54gp-qff8-946c
References
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-37709 · CVE Program
- CVE-2021-37709 · NVD
- FIRST EPSS
- GHSA-54gp-qff8-946c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences