Read the docs
TI-2021-15585 Aliases CVE-2021-37710GHSA-fc38-mxwr-pfhx

Cross-Site Scripting via SVG media files

Priority LOW 36CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a Cross-Site Scripting vulnerability via SVG media files. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

Why it matters now

EPSS 0.00736 54th percentileScored 2026-11-07
Fix Fixed shopware/core (Packagist): 6.4.3.1shopware/platform (Packagist): 6.4.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformup to 6.4.3.0—No fix listedCNA
—shopware/core (Packagist)before 6.4.3.16.4.3.1Patch availableGHSA-fc38-mxwr-pfhx
—shopware/platform (Packagist)before 6.4.3.16.4.3.1Patch availableGHSA-fc38-mxwr-pfhx
  • platform Vendorshopware Affected up to 6.4.3.0 Fixed in — No fix listed CNA
  • shopware/core (Packagist) Vendor— Affected before 6.4.3.1 Fixed in 6.4.3.1 Patch available GHSA-fc38-mxwr-pfhx
  • shopware/platform (Packagist) Vendor— Affected before 6.4.3.1 Fixed in 6.4.3.1 Patch available GHSA-fc38-mxwr-pfhx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.4.3.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.4.3.1 Vulnerable ·shopware

Remediation

  • Fix · GHSA-fc38-mxwr-pfhx shopware/core (Packagist) Fixed in 6.4.3.1 Advisory →
  • Fix · GHSA-fc38-mxwr-pfhx shopware/platform (Packagist) Fixed in 6.4.3.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37710
  2. 2026-10-03 Alias added: GHSA-fc38-mxwr-pfhx

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources