XSS vulnerability on Denounce plugin
Priority LOW 33CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.
Why it matters now
EPSS 0.03419 88th percentileScored 2026-11-07
Fix Fixed org.apache.jspwiki:jspwiki-main (Maven): 2.11.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache JSPWiki | Apache JSPWiki – 2.11.0.M8 | — | No fix listed | CNA |
| — | org.apache.jspwiki:jspwiki-main (Maven) | before 2.11.0 | 2.11.0 | Patch available | GHSA-cfqj-9g2g-w7q6 |
- Apache JSPWiki VendorApache Affected Apache JSPWiki – 2.11.0.M8 Fixed in — No fix listed CNA
- org.apache.jspwiki:jspwiki-main (Maven) Vendor— Affected before 2.11.0 Fixed in 2.11.0 Patch available GHSA-cfqj-9g2g-w7q6
Remediation
- Fix · GHSA-cfqj-9g2g-w7q6 org.apache.jspwiki:jspwiki-main (Maven) Fixed in 2.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-40369
- 2026-10-03 Alias added: GHSA-cfqj-9g2g-w7q6
References
Advisory 4
More Apache Jspwiki vulnerabilities
- TI-2022-11364 Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp CVSS 3.1MEDIUM 6.1
- TI-2022-10292 XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2 CVSS 3.1MEDIUM 6.1
- TI-2022-11366 Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin CVSS 3.1MEDIUM 6.1
- TI-2022-11365 Apache JSPWiki CSRF in UserPreferences.jsp CVSS 3.1MEDIUM 6.5
- TI-2024-17991 Apache JSPWiki: Cross-site scripting vulnerability on upload page CVSS 3.1MEDIUM 6.1
- TI-2026-23006 Apache JSPWiki: UserManager does not sanity-check user database at startup CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-40369 · CVE Program
- CVE-2021-40369 · NVD
- FIRST EPSS
- GHSA-cfqj-9g2g-w7q6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences