Improper authentication in moodle
Priority LOW 30CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
An authentication bypass risk was identified in the external database authentication functionality, due to a type juggling vulnerability.
Why it matters now
EPSS 0.00803 56th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.10, 3.10.7, 3.11.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 3.11 to 3.11.2, 3.10 to 3.10.6, 3.9 to 3.9.9 and earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.10 | 3.9.10 | Patch available | GHSA-2jxg-mv2m-j4r7 |
| — | moodle/moodle (Packagist) | 3.10 to before 3.10.7 | 3.10.7 | Patch available | GHSA-2jxg-mv2m-j4r7 |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.3 | 3.11.3 | Patch available | GHSA-2jxg-mv2m-j4r7 |
- moodle Vendor— Affected 3.11 to 3.11.2, 3.10 to 3.10.6, 3.9 to 3.9.9 and earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.10 Fixed in 3.9.10 Patch available GHSA-2jxg-mv2m-j4r7
- moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.7 Fixed in 3.10.7 Patch available GHSA-2jxg-mv2m-j4r7
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.3 Fixed in 3.11.3 Patch available GHSA-2jxg-mv2m-j4r7
Remediation
- Fix · GHSA-2jxg-mv2m-j4r7 moodle/moodle (Packagist) Fixed in 3.9.10 Advisory →
- Fix · GHSA-2jxg-mv2m-j4r7 moodle/moodle (Packagist) Fixed in 3.10.7 Advisory →
- Fix · GHSA-2jxg-mv2m-j4r7 moodle/moodle (Packagist) Fixed in 3.11.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-40693
- 2026-10-03 Alias added: GHSA-2jxg-mv2m-j4r7
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2021-40693 · CVE Program
- CVE-2021-40693 · NVD
- FIRST EPSS
- GHSA-2jxg-mv2m-j4r7 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-40693 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences