Read the docs
TI-2021-17652 Aliases CVE-2021-40695GHSA-gp4w-f57r-9rx3

It was possible for a student to view their quiz grade before it had been released, using a quiz web service.

Priority LOW 22CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

It was possible for a student to view their quiz grade before it had been released, using a quiz web service.

Why it matters now

EPSS 0.00853 58th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.3, 3.10.7, 3.9.10

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle3.11 to 3.11.2, 3.10 to 3.10.6, 3.9 to 3.9.9 and earlier unsupported versions—No fix listedCNA
—moodle/moodle (Packagist)3.11 to before 3.11.33.11.3Patch availableGHSA-gp4w-f57r-9rx3
—moodle/moodle (Packagist)3.10 to before 3.10.73.10.7Patch availableGHSA-gp4w-f57r-9rx3
—moodle/moodle (Packagist)3.9 to before 3.9.103.9.10Patch availableGHSA-gp4w-f57r-9rx3
  • moodle Vendor— Affected 3.11 to 3.11.2, 3.10 to 3.10.6, 3.9 to 3.9.9 and earlier unsupported versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.3 Fixed in 3.11.3 Patch available GHSA-gp4w-f57r-9rx3
  • moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.7 Fixed in 3.10.7 Patch available GHSA-gp4w-f57r-9rx3
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.10 Fixed in 3.9.10 Patch available GHSA-gp4w-f57r-9rx3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.9.0 to before 3.9.10; 3.10.0 to before 3.10.7; 3.11.0 to before 3.11.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.10; 3.10.0 to before 3.10.7; 3.11.0 to before 3.11.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-gp4w-f57r-9rx3 moodle/moodle (Packagist) Fixed in 3.11.3 Advisory →
  • Fix · GHSA-gp4w-f57r-9rx3 moodle/moodle (Packagist) Fixed in 3.10.7 Advisory →
  • Fix · GHSA-gp4w-f57r-9rx3 moodle/moodle (Packagist) Fixed in 3.9.10 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-40695
  2. 2026-10-03 Alias added: GHSA-gp4w-f57r-9rx3

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources