Read the docs
TI-2021-18027 Aliases CVE-2021-41188GHSA-4p3x-8qw9-24w9

Authenticated Stored XSS in Administration

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the `.htaccess` file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

Why it matters now

EPSS 0.00761 55th percentileScored 2026-11-07
Fix Fixed shopware (shopware): 5.7.6shopware/shopware (Packagist): 5.7.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopwarebefore 5.7.65.7.6Patch availableCNA
—shopware/shopware (Packagist)before 5.7.65.7.6Patch availableGHSA-4p3x-8qw9-24w9
  • shopware Vendorshopware Affected before 5.7.6 Fixed in 5.7.6 Patch available CNA
  • shopware/shopware (Packagist) Vendor— Affected before 5.7.6 Fixed in 5.7.6 Patch available GHSA-4p3x-8qw9-24w9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 5.7.6Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 5.7.6 Vulnerable ·shopware

Remediation

  • Fix · CNA shopware (shopware) Fixed in 5.7.6
  • Fix · GHSA-4p3x-8qw9-24w9 shopware/shopware (Packagist) Fixed in 5.7.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41188
  2. 2026-10-03 Alias added: GHSA-4p3x-8qw9-24w9

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources