Communities and collections administrators can escalate their privilege up to system administrator
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
DSpace is an open source turnkey repository application. In version 7.0, any community or collection administrator can escalate their permission up to become system administrator. This vulnerability only exists in 7.0 and does not impact 6.x or below. This issue is patched in version 7.1. As a workaround, users of 7.0 may temporarily disable the ability for community or collection administrators to manage permissions or workflows settings.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DSpace | DSpace | 7.0 to before 7.1 | 7.1 | Patch available | CNA |
| — | org.dspace:dspace-api (Maven) | 7.0 to before 7.1 | 7.1 | Patch available | GHSA-cf2j-vf36-c6w8 |
- DSpace VendorDSpace Affected 7.0 to before 7.1 Fixed in 7.1 Patch available CNA
- org.dspace:dspace-api (Maven) Vendor— Affected 7.0 to before 7.1 Fixed in 7.1 Patch available GHSA-cf2j-vf36-c6w8
Remediation
- Fix · CNA DSpace (DSpace) Fixed in 7.1
- Fix · GHSA-cf2j-vf36-c6w8 org.dspace:dspace-api (Maven) Fixed in 7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41189
- 2026-10-03 Alias added: GHSA-cf2j-vf36-c6w8
References
Patch 2
Advisory 2
More Dspace vulnerabilities
- TI-2022-13234 Path traversal vulnerabilities in DSpace JSPUI submission upload CVSS 3.1HIGH 8.2
- TI-2022-13235 Path traversal vulnerability in Simple Archive Format package import in DSpace CVSS 3.1HIGH 7.2
- TI-2016-08766 The XMLUI feature in DSpace before 3.6, 4.x before 4.5, and 5.x before 5.5 allows… CVSS 3.0HIGH 7.5
- TI-2022-13233 URL Redirection to Untrusted Site in Dspace JSPUI CVSS 3.1HIGH 7.1
- TI-2022-13232 Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature CVSS 3.1HIGH 7.1
- TI-2022-13231 Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools CVSS 3.1HIGH 7.1
Sources
- CVE-2021-41189 · CVE Program
- CVE-2021-41189 · NVD
- FIRST EPSS
- GHSA-cf2j-vf36-c6w8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences