Read the docs
TI-2022-13231 Aliases CVE-2022-31191GHSA-c558-5gfm-p2r8

Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools

Priority LOW 33CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

DSpace open source software is a repository application which provides durable access to digital resources. dspace-jspui is a UI component for DSpace. The JSPUI spellcheck "Did you mean" HTML escapes the data-spell attribute in the link, but not the actual displayed text. Similarly, the JSPUI autocomplete HTML does not properly escape text passed to it. Both are vulnerable to XSS. This vulnerability only impacts the JSPUI. Users are advised to upgrade. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00808 57th percentileScored 2026-11-07
Fix Fixed DSpace (DSpace): 6.4, 5.11org.dspace:dspace-jspui (Maven): 5.11, 6.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DSpaceDSpace6.0 to before 6.4; 4.0 to before 5.116.4, 5.11Patch availableCNA
—org.dspace:dspace-jspui (Maven)4.0 to before 5.115.11Patch availableGHSA-c558-5gfm-p2r8
—org.dspace:dspace-jspui (Maven)6.0 to before 6.46.4Patch availableGHSA-c558-5gfm-p2r8
  • DSpace VendorDSpace Affected 6.0 to before 6.4; 4.0 to before 5.11 Fixed in 6.4, 5.11 Patch available CNA
  • org.dspace:dspace-jspui (Maven) Vendor— Affected 4.0 to before 5.11 Fixed in 5.11 Patch available GHSA-c558-5gfm-p2r8
  • org.dspace:dspace-jspui (Maven) Vendor— Affected 6.0 to before 6.4 Fixed in 6.4 Patch available GHSA-c558-5gfm-p2r8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:duraspace:dspace:*:*:*:*:*:*:*:*after 4.0, up to 5.10; after 6.0, before 6.4VulnerableDSpace
  • cpe:2.3:a:duraspace:dspace:*:*:*:*:*:*:*:* Versions after 4.0, up to 5.10; after 6.0, before 6.4 Vulnerable ·DSpace

Remediation

  • Fix · CNA DSpace (DSpace) Fixed in 6.4, 5.11
  • Fix · GHSA-c558-5gfm-p2r8 org.dspace:dspace-jspui (Maven) Fixed in 5.11 Advisory →
  • Fix · GHSA-c558-5gfm-p2r8 org.dspace:dspace-jspui (Maven) Fixed in 6.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-31191
  2. 2026-10-03 Alias added: GHSA-c558-5gfm-p2r8

References

  • TI-2022-13234 Path traversal vulnerabilities in DSpace JSPUI submission upload CVSS 3.1HIGH 8.2
  • TI-2022-13235 Path traversal vulnerability in Simple Archive Format package import in DSpace CVSS 3.1HIGH 7.2
  • TI-2016-08766 The XMLUI feature in DSpace before 3.6, 4.x before 4.5, and 5.x before 5.5 allows… CVSS 3.0HIGH 7.5
  • TI-2021-18028 Communities and collections administrators can escalate their privilege up to system administrator CVSS 3.1HIGH 7.2
  • TI-2022-13233 URL Redirection to Untrusted Site in Dspace JSPUI CVSS 3.1HIGH 7.1
  • TI-2022-13232 Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature CVSS 3.1HIGH 7.1
See all 8 →

Sources