Path traversal vulnerabilities in DSpace JSPUI submission upload
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
DSpace open source software is a repository application which provides durable access to digital resources. dspace-jspui is a UI component for DSpace. The JSPUI resumable upload implementations in SubmissionController and FileUploadRequest are vulnerable to multiple path traversal attacks, allowing an attacker to create files/directories anywhere on the server writable by the Tomcat/DSpace user, by modifying some request parameters during submission. This path traversal can only be executed by a user with special privileges (submitter rights). This vulnerability only impacts the JSPUI. Users are advised to upgrade. There are no known workarounds. However, this vulnerability cannot be exploited by an anonymous user or a basic user. The user must first have submitter privileges to at least one Collection and be able to determine how to modify the request parameters to exploit the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DSpace | DSpace | 6.0 to before 6.4; 4.0 to before 5.11 | 6.4, 5.11 | Patch available | CNA |
| — | org.dspace:dspace-jspui (Maven) | 4.0 to before 5.11 | 5.11 | Patch available | GHSA-qp5m-c3m9-8q2p |
| — | org.dspace:dspace-jspui (Maven) | 6.0 to before 6.4 | 6.4 | Patch available | GHSA-qp5m-c3m9-8q2p |
- DSpace VendorDSpace Affected 6.0 to before 6.4; 4.0 to before 5.11 Fixed in 6.4, 5.11 Patch available CNA
- org.dspace:dspace-jspui (Maven) Vendor— Affected 4.0 to before 5.11 Fixed in 5.11 Patch available GHSA-qp5m-c3m9-8q2p
- org.dspace:dspace-jspui (Maven) Vendor— Affected 6.0 to before 6.4 Fixed in 6.4 Patch available GHSA-qp5m-c3m9-8q2p
Remediation
- Fix · CNA DSpace (DSpace) Fixed in 6.4, 5.11
- Fix · GHSA-qp5m-c3m9-8q2p org.dspace:dspace-jspui (Maven) Fixed in 5.11 Advisory →
- Fix · GHSA-qp5m-c3m9-8q2p org.dspace:dspace-jspui (Maven) Fixed in 6.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31194
- 2026-10-03 Alias added: GHSA-qp5m-c3m9-8q2p
References
Patch 3
More Dspace vulnerabilities
- TI-2022-13235 Path traversal vulnerability in Simple Archive Format package import in DSpace CVSS 3.1HIGH 7.2
- TI-2016-08766 The XMLUI feature in DSpace before 3.6, 4.x before 4.5, and 5.x before 5.5 allows… CVSS 3.0HIGH 7.5
- TI-2021-18028 Communities and collections administrators can escalate their privilege up to system administrator CVSS 3.1HIGH 7.2
- TI-2022-13233 URL Redirection to Untrusted Site in Dspace JSPUI CVSS 3.1HIGH 7.1
- TI-2022-13232 Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature CVSS 3.1HIGH 7.1
- TI-2022-13231 Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools CVSS 3.1HIGH 7.1
Sources
- CVE-2022-31194 · CVE Program
- CVE-2022-31194 · NVD
- FIRST EPSS
- GHSA-qp5m-c3m9-8q2p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences