Crashes due to overflow and `CHECK`-fail in ops with large tensor shapes
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.
Summary
TensorFlow is an open source platform for machine learning. In affected versions TensorFlow allows tensor to have a large number of dimensions and each dimension can be as large as desired. However, the total number of elements in a tensor must fit within an `int64_t`. If an overflow occurs, `MultiplyWithoutOverflow` would return a negative result. In the majority of TensorFlow codebase this then results in a `CHECK`-failure. Newer constructs exist which return a `Status` instead of crashing the binary. This is similar to CVE-2021-29584. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 | 2.6.1, 2.5.2, 2.4.4 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow-cpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow-cpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow-cpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow-gpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow-gpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-prcg-wp5q-rv7p |
| — | tensorflow-gpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-prcg-wp5q-rv7p |
- tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-prcg-wp5q-rv7p
- tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-prcg-wp5q-rv7p
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
- Fix · GHSA-prcg-wp5q-rv7p tensorflow (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-prcg-wp5q-rv7p tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41197
- 2026-10-03 Alias added: GHSA-prcg-wp5q-rv7p
References
Exploit 2
Patch 4
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-prcg-wp5q-rv7p
- https://github.com/tensorflow/tensorflow/commit/7c1692bd417eb4f9b33ead749a41166d6080af85
- https://github.com/tensorflow/tensorflow/commit/a871989d7b6c18cdebf2fb4f0e5c5b62fbc19edf
- https://github.com/tensorflow/tensorflow/commit/d81b1351da3e8c884ff836b64458d94e4a157c15
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-607.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-805.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-390.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41197 · CVE Program
- CVE-2021-41197 · NVD
- FIRST EPSS
- GHSA-prcg-wp5q-rv7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences