Read the docs
TI-2021-18041 Aliases CVE-2021-41202GHSA-xrqm-fpgr-6hhx

Overflow/crash in `tf.range`

Priority LOW 24CWE-681Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

TensorFlow is an open source platform for machine learning. In affected versions while calculating the size of the output within the `tf.range` kernel, there is a conditional statement of type `int64 = condition ? int64 : double`. Due to C++ implicit conversion rules, both branches of the condition will be cast to `double` and the result would be truncated before the assignment. This result in overflows. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Why it matters now

EPSS 0.00209 11th percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.6.1, 2.5.2, 2.4.4tensorflow (PyPI): 2.6.1, 2.5.2, 2.4.4+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.42.6.1, 2.5.2, 2.4.4Patch availableCNA
—tensorflow (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow (PyPI)before 2.4.42.4.4Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow-cpu (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow-cpu (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow-cpu (PyPI)before 2.4.42.4.4Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow-gpu (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow-gpu (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-xrqm-fpgr-6hhx
—tensorflow-gpu (PyPI)before 2.4.42.4.4Patch availableGHSA-xrqm-fpgr-6hhx
  • tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-xrqm-fpgr-6hhx
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-xrqm-fpgr-6hhx

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:*2.7.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:*2.7.0 rc1VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow (PyPI) Fixed in 2.4.4 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-xrqm-fpgr-6hhx tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41202
  2. 2026-10-03 Alias added: GHSA-xrqm-fpgr-6hhx

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources