Deadlock in mutually recursive `tf.function` objects
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-667 and the CVSS impact.
Summary
TensorFlow is an open source platform for machine learning. In affected versions the code behind `tf.function` API can be made to deadlock when two `tf.function` decorated Python functions are mutually recursive. This occurs due to using a non-reentrant `Lock` Python object. Loading any model which contains mutually recursive functions is vulnerable. An attacker can cause denial of service by causing users to load such models and calling a recursive `tf.function`, although this is not a frequent scenario. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 | 2.6.1, 2.5.2, 2.4.4 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow-cpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow-cpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow-cpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow-gpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow-gpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-h67m-xg8f-fxcf |
| — | tensorflow-gpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-h67m-xg8f-fxcf |
- tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-h67m-xg8f-fxcf
- tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-h67m-xg8f-fxcf
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* | 2.7.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* | 2.7.0 rc1 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
- Fix · GHSA-h67m-xg8f-fxcf tensorflow (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-h67m-xg8f-fxcf tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41213
- 2026-10-03 Alias added: GHSA-h67m-xg8f-fxcf
References
Advisory 2
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-622.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-820.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-405.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41213 · CVE Program
- CVE-2021-41213 · NVD
- FIRST EPSS
- GHSA-h67m-xg8f-fxcf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences