Read the docs
TI-2021-18055 Aliases CVE-2021-41216GHSA-3ff2-r28g-w7h9

Heap buffer overflow in `Transpose`

Priority LOW 33CWE-120Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-120 and the CVSS impact.

Summary

TensorFlow is an open source platform for machine learning. In affected versions the shape inference function for `Transpose` is vulnerable to a heap buffer overflow. This occurs whenever `perm` contains negative elements. The shape inference function does not validate that the indices in `perm` are all valid. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Why it matters now

EPSS 0.00161 5th percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.6.1, 2.5.2, 2.4.4tensorflow (PyPI): 2.6.1, 2.5.2, 2.4.4+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.42.6.1, 2.5.2, 2.4.4Patch availableCNA
—tensorflow (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow (PyPI)before 2.4.42.4.4Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow-cpu (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow-cpu (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow-cpu (PyPI)before 2.4.42.4.4Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow-gpu (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow-gpu (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-3ff2-r28g-w7h9
—tensorflow-gpu (PyPI)before 2.4.42.4.4Patch availableGHSA-3ff2-r28g-w7h9
  • tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-3ff2-r28g-w7h9
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-3ff2-r28g-w7h9

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:*2.7.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:*2.7.0 rc1VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow (PyPI) Fixed in 2.4.4 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-3ff2-r28g-w7h9 tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41216
  2. 2026-10-03 Alias added: GHSA-3ff2-r28g-w7h9

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources