Use after free in `CollectiveReduceV2`
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-416 and the CVSS impact.
Summary
TensorFlow is an open source platform for machine learning. In affected versions the async implementation of `CollectiveReduceV2` suffers from a memory leak and a use after free. This occurs due to the asynchronous computation and the fact that objects that have been `std::move()`d from are still accessed. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, as this version is the only one that is also affected.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-gpfh-jvf9-7wg5 |
| — | tensorflow-cpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-gpfh-jvf9-7wg5 |
| — | tensorflow-gpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-gpfh-jvf9-7wg5 |
- tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-gpfh-jvf9-7wg5
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-gpfh-jvf9-7wg5
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-gpfh-jvf9-7wg5
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1
- Fix · GHSA-gpfh-jvf9-7wg5 tensorflow (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-gpfh-jvf9-7wg5 tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-gpfh-jvf9-7wg5 tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41220
- 2026-10-03 Alias added: GHSA-gpfh-jvf9-7wg5
References
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-629.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-827.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-412.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41220 · CVE Program
- CVE-2021-41220 · NVD
- FIRST EPSS
- GHSA-gpfh-jvf9-7wg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences