Access to invalid memory during shape inference in `Cudnn*` ops
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-120 and the CVSS impact.
Summary
TensorFlow is an open source platform for machine learning. In affected versions the shape inference code for the `Cudnn*` operations in TensorFlow can be tricked into accessing invalid memory, via a heap buffer overflow. This occurs because the ranks of the `input`, `input_h` and `input_c` parameters are not validated, but code assumes they have certain values. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 | 2.6.1, 2.5.2, 2.4.4 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow-cpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow-cpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow-cpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow-gpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow-gpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-cqv6-3phm-hcwx |
| — | tensorflow-gpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-cqv6-3phm-hcwx |
- tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-cqv6-3phm-hcwx
- tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-cqv6-3phm-hcwx
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* | 2.7.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* | 2.7.0 rc1 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
- Fix · GHSA-cqv6-3phm-hcwx tensorflow (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-cqv6-3phm-hcwx tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41221
- 2026-10-03 Alias added: GHSA-cqv6-3phm-hcwx
References
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-630.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-828.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-413.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41221 · CVE Program
- CVE-2021-41221 · NVD
- FIRST EPSS
- GHSA-cqv6-3phm-hcwx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences