Segfault due to negative splits in `SplitV`
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
TensorFlow is an open source platform for machine learning. In affected versions the implementation of `SplitV` can trigger a segfault is an attacker supplies negative arguments. This occurs whenever `size_splits` contains more than one value and at least one value is negative. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 | 2.6.1, 2.5.2, 2.4.4 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow-cpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow-cpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow-cpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow-gpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow-gpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-cpf4-wx82-gxp6 |
| — | tensorflow-gpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-cpf4-wx82-gxp6 |
- tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-cpf4-wx82-gxp6
- tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-cpf4-wx82-gxp6
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* | 2.7.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* | 2.7.0 rc1 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-cpf4-wx82-gxp6 tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41222
- 2026-10-03 Alias added: GHSA-cpf4-wx82-gxp6
References
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-631.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-829.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-414.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41222 · CVE Program
- CVE-2021-41222 · NVD
- FIRST EPSS
- GHSA-cpf4-wx82-gxp6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences