Read the docs
TI-2021-18063 Aliases CVE-2021-41224GHSA-rg3m-hqc5-344v

`SparseFillEmptyRows` heap OOB read

Priority LOW 31CWE-125Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

TensorFlow is an open source platform for machine learning. In affected versions the implementation of `SparseFillEmptyRows` can be made to trigger a heap OOB access. This occurs whenever the size of `indices` does not match the size of `values`. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Why it matters now

EPSS 0.00208 10th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.6.1, 2.5.2, 2.4.4tensorflow (PyPI): 2.6.1, 2.5.2, 2.4.4+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.42.6.1, 2.5.2, 2.4.4Patch availableCNA
—tensorflow (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-rg3m-hqc5-344v
—tensorflow (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-rg3m-hqc5-344v
—tensorflow (PyPI)before 2.4.42.4.4Patch availableGHSA-rg3m-hqc5-344v
—tensorflow-cpu (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-rg3m-hqc5-344v
—tensorflow-cpu (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-rg3m-hqc5-344v
—tensorflow-cpu (PyPI)before 2.4.42.4.4Patch availableGHSA-rg3m-hqc5-344v
—tensorflow-gpu (PyPI)2.6.0 to before 2.6.12.6.1Patch availableGHSA-rg3m-hqc5-344v
—tensorflow-gpu (PyPI)2.5.0 to before 2.5.22.5.2Patch availableGHSA-rg3m-hqc5-344v
—tensorflow-gpu (PyPI)before 2.4.42.4.4Patch availableGHSA-rg3m-hqc5-344v
  • tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-rg3m-hqc5-344v
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-rg3m-hqc5-344v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
  • Fix · GHSA-rg3m-hqc5-344v tensorflow (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow (PyPI) Fixed in 2.4.4 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
  • Fix · GHSA-rg3m-hqc5-344v tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41224
  2. 2026-10-03 Alias added: GHSA-rg3m-hqc5-344v

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources