Arbitrary memory read in `ImmutableConst`
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
TensorFlow is an open source platform for machine learning. In affected versions the `ImmutableConst` operation in TensorFlow can be tricked into reading arbitrary memory contents. This is because the `tstring` TensorFlow string class has a special case for memory mapped strings but the operation itself does not offer any support for this datatype. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 | 2.6.1, 2.5.2, 2.4.4 | Patch available | CNA | |
| — | tensorflow (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow-cpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow-cpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow-cpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow-gpu (PyPI) | 2.6.0 to before 2.6.1 | 2.6.1 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow-gpu (PyPI) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-j8c8-67vp-6mx7 |
| — | tensorflow-gpu (PyPI) | before 2.4.4 | 2.4.4 | Patch available | GHSA-j8c8-67vp-6mx7 |
- tensorflow VendorGoogle Affected 2.6.0 to before 2.6.1; 2.5.0 to before 2.5.2; before 2.4.4 Fixed in 2.6.1, 2.5.2, 2.4.4 Patch available CNA
- tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow-cpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow-cpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.1 Fixed in 2.6.1 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow-gpu (PyPI) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-j8c8-67vp-6mx7
- tensorflow-gpu (PyPI) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-j8c8-67vp-6mx7
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* | 2.7.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* | 2.7.0 rc1 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.4.4; 2.5.0 to before 2.5.2; 2.6.0 to before 2.6.1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.1, 2.5.2, 2.4.4
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow-cpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow-cpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow-cpu (PyPI) Fixed in 2.4.4 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow-gpu (PyPI) Fixed in 2.6.1 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow-gpu (PyPI) Fixed in 2.5.2 Advisory →
- Fix · GHSA-j8c8-67vp-6mx7 tensorflow-gpu (PyPI) Fixed in 2.4.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41227
- 2026-10-03 Alias added: GHSA-j8c8-67vp-6mx7
References
Patch 2
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-636.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-834.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-419.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41227 · CVE Program
- CVE-2021-41227 · NVD
- FIRST EPSS
- GHSA-j8c8-67vp-6mx7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences