GeoJSON URL validation can expose server files and environment variables to unauthorized users
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
Metabase is an open source data analytics platform. In affected versions a security issue has been discovered with the custom GeoJSON map (`admin->settings->maps->custom maps->add a map`) support and potential local file inclusion (including environment variables). URLs were not validated prior to being loaded. This issue is fixed in a new maintenance release (0.40.5 and 1.40.5), and any subsequent release after that. If you’re unable to upgrade immediately, you can mitigate this by including rules in your reverse proxy or load balancer or WAF to provide a validation filter before the application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | before 0.40.5; 1.0.0 to before 1.40.5 | 0.40.5, 1.40.5 | Patch available | CNA |
- metabase VendorMetabase Affected before 0.40.5; 1.0.0 to before 1.40.5 Fixed in 0.40.5, 1.40.5 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:0.40.0:-:*:*:-:*:*:* | 0.40.0 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:0.40.1:*:*:*:-:*:*:* | 0.40.1 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:0.40.2:*:*:*:-:*:*:* | 0.40.2 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:0.40.3:*:*:*:-:*:*:* | 0.40.3 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:0.40.4:*:*:*:-:*:*:* | 0.40.4 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:1.40.0:-:*:*:enterprise:*:*:* | 1.40.0 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:1.40.1:*:*:*:enterprise:*:*:* | 1.40.1 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:1.40.2:*:*:*:enterprise:*:*:* | 1.40.2 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:1.40.3:*:*:*:enterprise:*:*:* | 1.40.3 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:1.40.4:*:*:*:enterprise:*:*:* | 1.40.4 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:0.40.0:-:*:*:-:*:*:* Versions 0.40.0 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:0.40.1:*:*:*:-:*:*:* Versions 0.40.1 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:0.40.2:*:*:*:-:*:*:* Versions 0.40.2 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:0.40.3:*:*:*:-:*:*:* Versions 0.40.3 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:0.40.4:*:*:*:-:*:*:* Versions 0.40.4 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:1.40.0:-:*:*:enterprise:*:*:* Versions 1.40.0 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:1.40.1:*:*:*:enterprise:*:*:* Versions 1.40.1 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:1.40.2:*:*:*:enterprise:*:*:* Versions 1.40.2 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:1.40.3:*:*:*:enterprise:*:*:* Versions 1.40.3 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:1.40.4:*:*:*:enterprise:*:*:* Versions 1.40.4 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 0.40.5, 1.40.5
Timeline
- 2024-11-12 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2021-41277
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
- TI-2026-36917 Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences