File system exposure in Metabase
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
Metabase is an open source business intelligence and analytics application. Metabase has a proxy to load arbitrary URLs for JSON maps as part of our GeoJSON support. While we do validation to not return contents of arbitrary URLs, there is a case where a particularly crafted request could result in file access on windows, which allows enabling an `NTLM relay attack`, potentially allowing an attacker to receive the system password hash. If you use Windows and are on this version of Metabase, please upgrade immediately. The following patches (or greater versions) are available: 0.42.4 and 1.42.4, 0.41.7 and 1.41.7, 0.40.8 and 1.40.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | 1.40.0 to before 1.40.7; 0.40.0 to before 0.40.7; 1.41.0 to before 1.41.6; 0.41.0 to before 0.41.6; 1.42.0 to before 1.42.3; 0.42.0 to before 0.42.3 | 1.40.7, 0.40.7, 1.41.6, 0.41.6, 1.42.3, 0.42.3 | Patch available | CNA |
- metabase VendorMetabase Affected 1.40.0 to before 1.40.7; 0.40.0 to before 0.40.7; 1.41.0 to before 1.41.6; 0.41.0 to before 0.41.6; 1.42.0 to before 1.42.3; 0.42.0 to before 0.42.3 Fixed in 1.40.7, 0.40.7, 1.41.6, 0.41.6, 1.42.3, 0.42.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* | 0.40.0 to before 0.40.8; 0.41.0 to before 0.41.7; 0.42.0 to before 0.42.4; 1.40.0 to before 1.40.8; 1.41.0 to before 1.41.7; 1.42.0 to before 1.42.4 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* Versions 0.40.0 to before 0.40.8; 0.41.0 to before 0.41.7; 0.42.0 to before 0.42.4; 1.40.0 to before 1.40.8; 1.41.0 to before 1.41.7; 1.42.0 to before 1.42.4 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 1.40.7, 0.40.7, 1.41.6, 0.41.6, 1.42.3, 0.42.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24853
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
- TI-2026-36917 Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences