Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow…
Priority CRITICAL 87Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow attackers to execute arbitrary commands on the server, at the server's privilege level. Authentication is not required for exploitation. The other fixed versions are 0.45.4.1, 1.45.4.1, 0.44.7.1, 1.44.7.1, 0.43.7.2, and 1.43.7.2.
Why it matters now
EPSS 0.99478 99th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* | before 0.43.7.2 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* | before 1.43.7.2 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* | 0.44.0 to before 0.44.7.1; 0.45.0 to before 0.45.4.1; 0.46.0 to before 0.46.6.1 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* | 1.44.0 to before 1.44.7.1; 1.45.0 to before 1.45.4.1; 1.46.0 to before 1.46.6.1 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* Versions before 0.43.7.2 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* Versions before 1.43.7.2 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* Versions 0.44.0 to before 0.44.7.1; 0.45.0 to before 0.45.4.1; 0.46.0 to before 0.46.6.1 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* Versions 1.44.0 to before 1.44.7.1; 1.45.0 to before 1.45.4.1; 1.46.0 to before 1.46.6.1 Vulnerable ·Metabase
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-38646
- 2026-10-03 Alias added: GHSA-jg32-8h6w-x7vg
References
Other 5
- https://github.com/metabase/metabase/releases/tag/v0.46.6.1
- https://news.ycombinator.com/item?id=36812256
- https://github.com/metabase/metabase/issues/32552
- http://packetstormsecurity.com/files/174091/Metabase-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/177138/Metabase-0.46.6-Remote-Code-Execution.html
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
- TI-2026-36917 Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write CVSS 3.1CRITICAL 10.0
Sources
- CVE-2023-38646 · CVE Program
- CVE-2023-38646 · NVD
- FIRST EPSS
- GHSA-jg32-8h6w-x7vg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences